re = /(\b|\^(?:OR|AND)?)(name|first_name|last_name|city)\b/
str = 'city=Houston^ORlast_name=Cervantsz^ORfirst_name=John^name=don'
subst = '$1user.$2'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result