import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<protocol>(?:https?:\\/\\/?)+(?:www(?!.))?)?(?<tdl>[a-zA-Z0-9@:._-]{2,256}\\.[a-z0-9]{2,6}(?:[:0-9]{1,5})?)(?<path>(?:\\/)[-a-zA-Z0-9\\/_]+)?(?<params>[-a-zA-Z0-9?%#+()=&]+)?";
final String string = "http://foo.com/blah_blah\n"
+ "http://foo.com/blah_blah/\n"
+ "https://www.example.com/wpstyle/?p=364\n"
+ "https://www.example.com/wpstyle/wpath/?p=364&?param=this\n"
+ "https://www.example.com/foo/?bar=baz&inga=42&quux\n"
+ "google.com\n"
+ "www.google.com\n"
+ "http://foo.com:\n"
+ "http://foo.com:8080/blah_blah\n"
+ "https://www.example.com/foo/?bar=baz&inga=42&quux\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}