Please enable JavaScript to use regex101
/
^
r
e
g
e
x
[
\
-
_
]
?
1
0
1
$
/
i
Reg
ular
Ex
pressions
101
Reg
ular
Ex
pressions
101
Upgrade to Pro
Enterprise
Regular Expression
/
^(((0)|([1-9]\d?)|(1\d\d)|(2[0-5]{2}))\.?){0,3}((0)|([1-9]\d?)|(1\d\d)|(2[0-5]{2}))?$
/
gm
Input 1
1
New
255.255.255.255 192.168.0.1 0.0.0.0 192.168.0. 192.168.0 192.1 0 33.33.33.33 2.2.99 255.255.255.255. 192.168.0.270 0.0.0.a 255.255.255. 255 192.168.0.. 0.0.00.0