import Foundation
let pattern = #"£(?:1(?:[0-4](?:[0-9]?(?:[.,][0-9]{1,2})?)?|5(?:[0-4](?:[.,][0-9]{1,2})?|5(?:[.,]00?)?)|[6-9]?(?:[.,][0-9]{1,2})?)?|[2-9][0-9]?(?:[.,][0-9]{1,2})?)(?![.,]?[0-9])"#
let regex = try! NSRegularExpression(pattern: pattern, options: [.anchorsMatchLines, .allowCommentsAndWhitespace])
let testString = #"""
£155.12
£155
£1
£124,44
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)