using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\B([a-z](?=[A-Z])|[A-Z](?=[a-z]))";
string substitution = @"$1 ";
string input = @"Inverted HFFSfor Primary Wrap Or Secondary Multi Wrap
HFFSwith PDSPbackgroud Feederlense & Product Alignerigit
HFFSwith Cooler JKLHbetween Feeder & Product Aligner";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}