package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^(?:00|\+)[0-9]?()[0-9](\s|\S)(\d[0-9]{6,14})$`)
var str = `+14917672662642`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}