# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?:\b[Tt]o:|\\b002;)\s*(.+?)\s*<[^<>@]+@[^<>@]+>//gmi;t' <<< "To: John Lennon <John.Lennon@gmail.com> \b002; Paul McCartney <Paul.McCartney@yahoo.com> \b002;"