const regex = new RegExp('(?:\\b[Tt]o:|\\\\b002;)\\s*(.+?)\\s*<[^<>@]+@[^<>@]+>', 'gmi')
const str = `To: John Lennon <John.Lennon@gmail.com> \\b002; Paul McCartney <Paul.McCartney@yahoo.com> \\b002;`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);