re = /https:\/\/[^\s]*/
str = 'текст текст https://toster.ru/question/new/?get любой текст'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end