re = /\.hb-fill-top(?::.*)?/
str = '.hb-fill-top::before
.hb-fill-top:hover::before
.hb-fill-top
.hb-fill-top:hover'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end