# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^\\/?[^\\/]*(\\/(.*))?$/\/pasta_do_site\/$2/gm;t' <<< "/qualquer-coisa/index.php
/qualquer-coisa1/index.php
/qualquer-coisa2/index.php
/qualquer-coisa3/index.php
/qualquer-coisa4/index.php
/qualquer-coisa5/index.php
/qualquer-coisa6/
/qualquer-coisa7"