using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^\/?[^\/]*(\/(.*))?$";
string substitution = @"/pasta_do_site/$2";
string input = @"/qualquer-coisa/index.php
/qualquer-coisa1/index.php
/qualquer-coisa2/index.php
/qualquer-coisa3/index.php
/qualquer-coisa4/index.php
/qualquer-coisa5/index.php
/qualquer-coisa6/
/qualquer-coisa7";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}