import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^\\/?[^\\/]*(\\/(.*))?$";
final String string = "/qualquer-coisa/index.php\n"
+ "/qualquer-coisa1/index.php\n"
+ "/qualquer-coisa2/index.php\n"
+ "/qualquer-coisa3/index.php\n"
+ "/qualquer-coisa4/index.php\n"
+ "/qualquer-coisa5/index.php\n"
+ "/qualquer-coisa6/\n"
+ "/qualquer-coisa7";
final String subst = "/pasta_do_site/$2";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}