using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<=<li><a>)[\u0400-\u04FF]{1,}_";
string input = @"<div class=""brd"">
<ul class=""brd-navigation"">
<li><a>Текст</a></li>
<li><a>Текст</a></li>
<li><a>Текст</a></li>
<li><a>Текст_</a></li>
<li><a>Текст</a></li>
</ul>
</div>";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}