re = /(?<=<li><a>)[\u0400-\u04FF]{1,}_/m
str = '<div class="brd">
<ul class="brd-navigation">
<li><a>Текст</a></li>
<li><a>Текст</a></li>
<li><a>Текст</a></li>
<li><a>Текст_</a></li>
<li><a>Текст</a></li>
</ul>
</div>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end