using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @",(?=\s*\))";
string substitution = @"";
string input = @"item_id IN ( '1','2',) AND nt_id IN ( 'er1','er2',) AND";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}