$re = '/,(?=\s*\))/';
$str = 'item_id IN ( \'1\',\'2\',) AND nt_id IN ( \'er1\',\'er2\',) AND';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;