#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^.*[\d$&+,:;=?@#|'<>.^*()%!-].*[\d$&+,:;=?@#|'<>.^*()%!-].*$"
Local $sString = "1sfdfsd2" & @CRLF & _
"" & @CRLF & _
"asd12" & @CRLF & _
"" & @CRLF & _
"3asd@df" & @CRLF & _
"" & @CRLF & _
"22" & @CRLF & _
"" & @CRLF & _
"@^" & @CRLF & _
"" & @CRLF & _
"2*" & @CRLF & _
"" & @CRLF & _
"*sff)f" & @CRLF & _
"" & @CRLF & _
".(()2fd" & @CRLF & _
"" & @CRLF & _
"d1cdddd" & @CRLF & _
"@" & @CRLF & _
"aa@" & @CRLF & _
"@aaaa" & @CRLF & _
"xrg@aaaa" & @CRLF & _
"xrg4aaaa" & @CRLF & _
"xrg4aaaa"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")