package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^([а-я]+[А-Я][а-я]*|[а-я]*[А-Я][а-я]+)$`)
var str = `Мама
ПетР
авТо
песня
гриБ
Яблоко
яБлоко
ябЛоко
яблОко
яблоКо
яблокО
Три богатыря
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}