package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)((^(?:\S+\s+\n?){1,2})\w+)`)
var str = `Brian Ball - working to make online income simple
((?:(\S+\s+){1,2})\w+)`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}