$re = '~((^(?:\S+\s+\n?){1,2})\w+)~m';
$str = 'Brian Ball - working to make online income simple
((?:(\\S+\\s+){1,2})\\w+)';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);