re = /^(?=\w{6}).*\d\d/m
str = 'bana12
abc123
banan1
airplanes
astronaut
123
1234
ab1c23'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end