import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?P<type>TRANSPORT)(?:::)(?P<desc>[\\w#()/]*)";
final String string = "TRANSPORT::FNHT_ASR9001_TO_511_CORE_TE0/3/0/12_BE80\n"
+ "TRANSPORT::FRTN_ASR9010";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}