#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\[(plantuml.+)\]\s+\.{4}\s([\s\S]+?(?=^\.{4}))\.{4}"
Local $sString = "= Title" & @CRLF & _
"" & @CRLF & _
"[plantuml, target=diagram-classes, format=png]" & @CRLF & _
"...." & @CRLF & _
"class BlockProcessor" & @CRLF & _
"class DiagramBlock" & @CRLF & _
"class DitaaBlock" & @CRLF & _
"class PlantUmlBlock" & @CRLF & _
"" & @CRLF & _
"BlockProcessor <|-- DiagramBlock" & @CRLF & _
"DiagramBlock <|-- DitaaBlock" & @CRLF & _
"DiagramBlock <|-- PlantUmlBlock" & @CRLF & _
"...." & @CRLF & _
"" & @CRLF & _
"[plantuml, target=blabla, fasdf=asfdas]" & @CRLF & _
"...." & @CRLF & _
"class BlockProcessor" & @CRLF & _
"class DiagramBlock" & @CRLF & _
"class DitaaBlock" & @CRLF & _
"class PlantUmlBlock" & @CRLF & _
"" & @CRLF & _
"BlockProcessor <|... DiagramBlock" & @CRLF & _
"DiagramBlock <|...... DitaaBlock" & @CRLF & _
"DiagramBlock <|..... PlantUmlBlock" & @CRLF & _
"...." & @CRLF & _
"" & @CRLF & _
"[source, java]" & @CRLF & _
"...." & @CRLF & _
"class BlockProcessor" & @CRLF & _
"class DiagramBlock" & @CRLF & _
"class DitaaBlock" & @CRLF & _
"class PlantUmlBlock" & @CRLF & _
"" & @CRLF & _
"BlockProcessor <|-- DiagramBlock" & @CRLF & _
"DiagramBlock <|-- DitaaBlock" & @CRLF & _
"DiagramBlock <|-- PlantUmlBlock" & @CRLF & _
"...." & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")