using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"change://(?:problem/)?(\d+)";
string input = @"<change://problem/59689726> This is a test1
change://1234567 This is a test2";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}