# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/[^\p{Alnum}\s]//gmu;t' <<< "!\\"#$%&'()*+,-./:;<=>?@[\\]^_`{|}~(hello)
foo bar baz"