using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"[^\p{Alnum}\s]";
string substitution = @"";
string input = @"!\""#$%&'()*+,-./:;<=>?@[\\]^_`{|}~(hello)
foo bar baz";
RegexOptions options = RegexOptions.Multiline | RegexOptions.CultureInvariant;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}