use strict;
my $str = '!\\"#$%&\'()*+,-./:;<=>?@[\\\\]^_`{|}~(hello)
foo bar baz';
my $regex = qr/[^\p{Alnum}\s]/mup;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";