using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\{((?:[^{}]|(?R))+)\}";
string input = @"Eu sou uma string {dentro de uma string {dentro de outra} }
String {com {vários {níveis {de } chaves}} aninhadas}.
String {com mais {de} um} trecho {com {chaves}}
String com {chaves {desbalanceadas}
Chaves {} vazias
Apenas {um par de} chaves
Somente abre { chaves.";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}