import Foundation
let pattern = #"\{((?:[^{}]|(?R))+)\}"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
Eu sou uma string {dentro de uma string {dentro de outra} }
String {com {vários {níveis {de } chaves}} aninhadas}.
String {com mais {de} um} trecho {com {chaves}}
String com {chaves {desbalanceadas}
Chaves {} vazias
Apenas {um par de} chaves
Somente abre { chaves.
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)