package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^„(.*)“[\r\n]*Auszug aus: (.*)\. „(.*)\.“ iBooks.$`)
var str = `„Das ist ein Test.“
Auszug aus: Neil DeGrasse Tyson. „Astrophysics for People in a Hurry.“ iBooks.`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}