# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\B\.\w+,? ?//g;t' <<< "ad, ghost, hg, .hi, jk, find.jpg, dam.ark, haji, jive.pdf, .find, home, .war, .milk, raj, .ker"