package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^[^()\n]+\([^()]*\)\s*
\{
(?:[^{}]*|(?R))+
\}`)
var str = `int firt(){
if () {
}
}
customtype second(){
if () {
}
for(){
}
}`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}