$re = '/(\')((?:[^\\\\\']*)(?:\\\\\'[^\\\\\']*)*)(\')/m';
$str = '{\'hi\': \'coxxxxol\'}{\'lol\': \'what\\\'e"ver\'}
\'\'\'\'\'\'\'\'\'\'\'\'\'\'\'\'\'\'\'\'\'\'\'\'
\'\'\'\'\'\'\'\'\'\'\'\'\'\'\'\'\'\'\'\'\'\'\'\'\'\'
title=\'Wow \'this\' is great\'';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);