re = /(')((?:[^\\']*)(?:\\'[^\\']*)*)(')/m
str = '{\'hi\': \'coxxxxol\'}{\'lol\': \'what\\\'e"ver\'}
\'\'\'\'\'\'\'\'\'\'\'\'\'\'\'\'\'\'\'\'\'\'\'\'
\'\'\'\'\'\'\'\'\'\'\'\'\'\'\'\'\'\'\'\'\'\'\'\'\'\'
title=\'Wow \'this\' is great\''
# Print the match result
str.scan(re) do |match|
puts match.to_s
end