?repeats the group contents below at most once:
the literal (3210 / 408 / 2016)
\d{2}a digit, repeated exactly 2 times
:the literal : (5810 / 728 / 3A16)
\d{2}a digit, repeated exactly 2 times
Group 4(:\d{2}([.:]\d)?)? ?repeats the group contents below at most once:
:the literal : (5810 / 728 / 3A16)
\d{2}a digit, repeated exactly 2 times
?repeats the group contents below at most once:
.the literal . (4610 / 568 / 2E16)
:the literal : (5810 / 728 / 3A16)
\da digit