import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "submitted by .+ ([a-zA-Z'\\-_]+)( [a-zA-Z'\\-_]+\\.)? :";
final String string = "The following records request has been submitted by Bryan Trummer :\n"
+ "The following records request has been submitted by Ray Parker Jr. :\n"
+ "The following records request has been submitted by William Stanley Preston, Esq. :\n"
+ "The following records request has been submitted by Marshall Bruce Mathers III :\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}