$re = '/\[[^\][]*]\(([^()]*)\)/m';
$str = 'This [close](animal) is a dog';
$subst = "{$1}";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;