import re
regex = re.compile(r"^\(?\\?\"(\d{1,3}[-]?\d{0,3})[\s|,|,\s]?(.*[A-Za-z])\\?\",?(\d{1,2}?.?\d{3,9})?,?([-|+|\s]\d{1,2}?.?\d{3,9})?[A-Za-z]?\)?", flags=re.MULTILINE)
test_str = ("(\"197 STATION ROAD, KINGS HEATH, BIRMINGHAM B14 7TB\",52.434992,-1.8990985)\n"
"(\\\"9-12, BOW STREET, LONDON, WC2E 7AH\\\",51.5136001,-0.1229336)\n"
"(\\\"14 STATION ROAD, LONDON SE20 7BQ\\\",51.41886,-0.0545021)\n"
"\\\"14 Station road London SE20 7BQ UK\\\"\n"
"\"14 Station road London SE20 7BQ UK\"\n\n")
subst = "$1 $2 [$3] [$4]"
result = regex.sub(subst, test_str)
if result:
print(result)