// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)([\w\s]){2}([^;;])").unwrap();
let string = "correct;;1391;;Yoga Liang;;jy3hmq2piajvq8mopys4levre29wpx8399zdmwwy;;40143177177154";
let substitution = "sa";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}