use strict;
my $str = '234-345
543879
654 899,,';
my $regex = qr/^(.{3})(-| )?(.{3}),*$/mp;
my $subst = '$1-$3';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";