const regex = /[à-ü]/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('[à-ü]', 'gm')
const str = `÷
æ
--- o "á" abaixo está em NFD e não é pego pela regex
á
--- já esse em NFC é pego
á`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}