// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
  let regex = Regex::new(r"(?m)[à-ü]").unwrap();
  let string = "÷
æ
--- o \"á\" abaixo está em NFD e não é pego pela regex
á
--- já esse em NFC é pego
á";
  
  // result will be an iterator over tuples containing the start and end indices for each match in the string
  let result = regex.captures_iter(string);
  
  for mat in result {
    println!("{:?}", mat);
  }
}