package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?s)\D*(\d+)\D+(\d+)\D+(\d+)\D*`)
var str = `81cm:36cm:50cm
60L:30l:30h
12@#[]{}!($£ :34%_+=/;:56?,.'azerrtyuuioQSDFFGHJK
80-80-40
60+60+80
38 x 38 x 43
et même des trucs avant 60L : 30l: 30H et plein de trucs après;`
var substitution = "$1:$2:$3\n"
fmt.Println(re.ReplaceAllString(str, substitution))
}