#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)[a-z&&[^aeiou]]([a-z&&[^aeiou]][a-z&&[^aeiou]])*[aeiou][a-z&&[^aeiou]]([a-z&&[^aeiou]][a-z&&[^aeiou]])*"
Local $sString = "assignment number whatever what" & @CRLF & _
"topology" & @CRLF & _
"asstrwo" & @CRLF & _
"hop"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")