#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?ix)\G(?!\A)" & @CRLF & _
"(?: [^\[]+ | (?! \[/?quote). )*+ \K" & @CRLF & _
"(" & @CRLF & _
" \[quote[^\]]*\]" & @CRLF & _
" (?: [^\[]+ | (?!\[/?quote). | (?1) )*+ " & @CRLF & _
" \[/quote\]" & @CRLF & _
")" & @CRLF & _
"| \[quote[^\]]*\] \K"
Local $sString = "" & @CRLF & _
"[quote]lol [quote=2][quote=3] a[/quote]b[/quote]c[/quote]" & @CRLF & _
"" & @CRLF & _
"[quote] a [quote=bob]a[/quote] text [quote][quote]a[/quote]b[/quote]c[/quote]" & @CRLF & _
"" & @CRLF & _
""
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)