import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "([^ \\\\])\\$0([^ \\\\])";
final String string = "Hello '$0'. '$0' becomes the World. \\$0 This shall remain \\$0\n"
+ "Hello \"$0\". \"$0\" becomes the World. \\$0 This shall remain \\$0\n"
+ "Hello [$0]. [$0] becomes the World. \\$0 This shall remain \\$0";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}