$re = '/([^ \\\\])\$0([^ \\\\])/m';
$str = 'Hello \'$0\'. \'$0\' becomes the World. \\$0 This shall remain \\$0
Hello "$0". "$0" becomes the World. \\$0 This shall remain \\$0
Hello [$0]. [$0] becomes the World. \\$0 This shall remain \\$0';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);