package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?s)> \[!(CAUTION|IMPORTANT|NOTE|TIP|WARNING)\].*?(\n|$)`)
var str = `> [!NOTE]
> This is a note
> [!WARNING]
> THis is a warning`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}