#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(你知道)?#的?(简介|介绍|知识)(吗|不|嘛|么)?$"
Local $sString = "介绍一下#" & @CRLF & _
"给我说说#" & @CRLF & _
"给我介绍一下#吧" & @CRLF & _
"" & @CRLF & _
"说说#是什么" & @CRLF & _
"介绍一下#是啥" & @CRLF & _
"什么是#" & @CRLF & _
"#是啥啊" & @CRLF & _
"" & @CRLF & _
"#的简介" & @CRLF & _
"你知道#的知识吗"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")